ACE is not dead – 1.5 is coming

Add comments

Actually, I was not updating ACE, since I havn’t got ANY problems with it, on the sites I’am using it, on a daily basis.

Thus I can’t do anything with comments that say “it does not work with wp 2.9”. Because it does work. Although if you can’t see any difference for example in widgets, itΒ  can be a theme issue. Or if it’s suddenly stop working, it can be an ISP issue, who upgraded PHP wihtout notifying you.

Please, if you really want to help, stop saying “it does not work”, please describe the problem correctly, than I could help ypu work it out.

About the new version

New exclusion sections have been added like 404 error page, Attachment page and so on.
New native Categories widgets support have been added, and there is a new configuration page for Categories Widget. Recent comments and Recent posts configuration is on the way. It will be available in final ACE 1.5.

And also some translations have been submitted in the mean time.
I’ll include them as well.

February 4th 2010 Releases

36 Responses to “ACE is not dead – 1.5 is coming”

  1. sjefen6 Says:

    I suggest you look into errors with php 5.3. I will turn on error reporting and post the errors I am getting.

  2. DjZoNe Says:

    I’m currently working under 5.3 πŸ™‚

  3. sjefen6 Says:

    My website currently have ace enabeled and are becouse of it having issues with repeted posts and simmular. Error reporting is enabled soon (host is taking some time enabling it). I started having issues when my host changed to php 5.3… Im using one.com and my website is goldclone.org

  4. sjefen6 Says:

    Warning: Parameter 1 to ace_where() expected to be a reference, value given in /customers/goldclone.org/goldclone.org/httpd.www/wp-includes/plugin.php on line 166

    Warning: Parameter 1 to ace_join() expected to be a reference, value given in /customers/goldclone.org/goldclone.org/httpd.www/wp-includes/plugin.php on line 166

    I will keep error reporting on for a few more hours

  5. DjZoNe Says:

    Try out the current developement version:

    http://downloads.wordpress.org/plugin/advanced-category-excluder.zip

  6. sjefen6 Says:

    Seems to have solved it πŸ˜€
    Thanks!

  7. Dhany Says:

    I’d like to contribute in Bahasa Indonesia translation. Is that possible?

  8. DjZoNe Says:

    Hi Dhany,
    what a question πŸ™‚
    It’s possible for sure, but a lot of things are changing in ACE 1.5, I guess 1.4.x translations won’t work at all πŸ™‚

  9. Maurice Says:

    I hope this is the right place for a bug report:

    WordPress: 2.9
    Php: 5.3.0
    MySql 5.1.41
    Language settings – default (all English)
    Active plugins: ACE ACE Widgets
    Theme: WP classic 1.5
    Long category list, no exclusions set yet

    Problem: many posts are shown repeatedly, and two lines appear at the top of the blog:

    Warning: Parameter 1 to ace_where() expected to be a reference, value given in /Users/mauricenaftalin/Sites/maurice/blog/wp-includes/plugin.php on line 166

    Warning: Parameter 1 to ace_join() expected to be a reference, value given in /Users/mauricenaftalin/Sites/maurice/blog/wp-includes/plugin.php on line 166

  10. DjZoNe Says:

    Maurice, until ACE 1.5 is not released, a solution for PHP 5.3 is here:

    http://ace.dev.rain.hu/2009/05/13/ace-143/#comment-6483

  11. Dhany Says:

    I’ll be waiting until the release of ACE 1.5 to work on the translation.

  12. Tim Says:

    Thanks for your work!

    Using WP 2.9.2 and ACE Version 1.4.3, I’ve found that a sticky post will be displayed on my homepage even if its category is excluded..

    otherwise, looks great (in the simple way that I use the plugin atm!)

    Thanks, Tim

  13. celiapgt Says:

    Thanks, Hungary! You are doing an excellent work! WP 2.9.1 ACE 1.43 is working correctly! Thaaaaaanks!

  14. tester Says:

    i tried the 1.5alpha version but it’s still impossible to show category posts widget content on the home page while the category is excluded for home.

    is there any workaround for this? running wp 2.9.2

    thnx.

  15. DjZoNe Says:

    Category widgets currently not compatibe with WordPress 2.9. Rewrtiting is in progress πŸ™‚

  16. Lisa Says:

    I have an issue, and I want to make sure I understand functionality correctly.

    We are on WP 2.9.2 and ACE 1.4.3.

    We have a post, which has 3 categories. One of those categories is “banned” from the home page. The other two categories are not banned, that is, we want it on the home page.

    The issue is: the post IS in fact hidden. I am confused because your FAQ states:

    “If I post in one category that is hidden, and another one as well, which is not. What will happen?

    Then, your post won’t be hidden. This plugin only hides your post, if all of the defined categories selected for exclusion.”

  17. DjZoNe Says:

    FAQ is old.

  18. Lisa Says:

    So, what then is the actual way it works?
    What is the answer to this question:
    β€œIf I post in one category that is hidden, and another one as well, which is not, What will happen?”

  19. Hgrg Says:

    Hy
    I’ve got problems with the plugin under 3.0ß1 its not poppin any errors, its just not excluding the category’s posts πŸ™
    I’d be glad to know when its next upcoming version is gona be released.
    Thanks for your work!

  20. Paul Says:

    WP 2.9.2 does not work with ACE 1.4.3 (((((((((((((

  21. DjZoNe Says:

    Please be more precise, WHAT is not working?
    Because I use it on many WP 2.9.2 installs.

  22. Shawn Says:

    Is there a way to use this to hide a post on the main page for a certain category?

    Thank you

  23. DjZoNe Says:

    A way? πŸ˜€
    This plugin is for that purpose! πŸ˜€

  24. Jon Says:

    Is there an option in this version that allows for sticky posts in excluded categories to still be shown in the home section of the blog?

    If there is none, can i know the specific plugin file to edit (and the specific lines of code if its not too much to ask πŸ™‚ ).

    Thank you very much.

    (to moderator: please delete the previous post and this line, i mispelled stick for sticky, thanks)

  25. Ulf Benjaminsson Says:

    There’s an issue with ACE ignoring the incoming value when filtering the “excluded”-parameter, and thus breaking wp_list_pages and wp_pages_menu I posted a fix over at pastebin: http://pastebin.com/7aq8hdiR

    I’ll try and paste the code here to:
    function ace_list_pages_excludes($excludes)
    {
    $filter = ace_get_section();
    $posts_to_exclude = get_option(“ace_page_sections_”.$filter);
    $posts_to_exclude = array_merge($excludes, explode(“,”, $posts_to_exclude));
    return $posts_to_exclude;
    }

  26. Jeremy Says:

    I would like to understand if there is a setting that controls whether an excluded category appears in WP’s Next and Previous links.

    At the moment an excluded post appears there, and then gives an error if someone clicks on the link because it does not display in any section. I could enable display as single post, but I prefer to hide everywhere.

    How do I exclude a category from Next/Previous links?

    Thanks

  27. Jeremy Says:

    ACE was working fine on my site, until I migrated to a new host. Now I have had to disable the plugin, because one problem is that it displays Auto Draft posts on the front page.

    I am sorry about this, because it was a very useful plugin.

  28. Heather Says:

    ACE was working fine till I upgraded my wordpress. Suddenly my widget gives aphp code error when any category is selected. I really loved this plugin before I upgraded my wordpress. Now I know I should save a back up prior to updates, but too late to revert now :(any advice? I didn’t disable the plugin so the errors r still available

  29. dskmusic Says:

    Advanced Category Excluder Widgets cant uptaded to 1.4.4 last version!! I check the update option, but when I execute nothings happends.. always showing “update available”

  30. DjZoNe Says:

    Update the main one, and widgets will be updated as well.

  31. Matt Gibson Says:

    Sorry, I’m also having the problem with the Widgets saying they need an update even after I update them. I’ve got the latest version of the main plugin — 1.4.4 — but whenever I try to upgrade the widgets to 1.4.4, it says it’s downloading and installing 1.4.4, but then shows them as 1.4.3 and tells me they still need updating.

    Am I missing something?

    Thanks,

    Matt

  32. dskmusic Says:

    I’m upodate the main, the problem happends after doing it.

  33. DjZoNe Says:

    The widgets are in just the same zip archive as the main, and installs to the same directory as well.

  34. dskmusic Says:

    I updated directly from wordpress, and manually downloading the zip file. Still getting the widget not updated…

  35. Matt Gibson Says:

    Yep, they’re in the same zip archive, but their version is set to 1.4.3 (in the header of ace-widgets.php.) Is this maybe causing the problem? They show up separately on the Plugins page in WordPress, and are showing as having an update to version 1.4.4 available.

    Thanks,

    Matt

  36. Heather Says:

    Can you help!?? everything was running perfectly until i updated WP (and didnT have a back up of my site) and then suddenly the ACE gives an error when clicked on. under the widget: Select Additional Post Topics — anything u choose will result in –>”Warning: Cannot modify header information – headers already sent by (output started at /hermes/bosoraweb067/b1197/ipg.holisticundergroundo/holisticunderground.org/index.php:1) in /hermes/bosoraweb067/b1197/ipg.holisticundergroundo/holisticunderground.org/wp-includes/pluggable.php on line 876″

    i have been told by coding friends that something is wrong with the heirachy but i donT know what to fix. Please advise…. i like this theme but if its a problem with just this theme i will find another…. HELP!!